<!doctype html>
<html lang="en">

<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
 <meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
 <meta name="google-site-verification" content="4GrvUcextHKMFj91p1HDoOkOw9cvgqpM9_PmZtIoSDE" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="norton-safeweb-site-verification" content="4-8q940c68tts8mkrawweyw-fb0a-n0z-hr50v9pgp3alu7yrtpnma8cbusdizeq5y9-i8ztd697gah1hnnckhcmfuc99-gljisqjinmyn7xy8teaglw2fafhn5s0zue" />
<meta name="viewport" content="width=1040">

<!-- Escape from Frames  -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script>
<link href="https://fonts.googleapis.com/css?family=Roboto" rel="stylesheet">
<link rel="stylesheet" href="https://rivertonroll.com/wp-content/themes/alambre/style.css?1533069294" type="text/css" media="screen, projection" />

<link href="https://rivertonroll.com/feed" rel="alternate" title="Riverton Roll RSS Feed" type="application/rss+xml" />
<link href="https://rivertonroll.com/feed/atom" rel="alternate" title="Riverton Roll Atom Feed" type="application/atom+xml" />
<link href="https://rivertonroll.com/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://rivertonroll.com/wp-includes/css/dist/block-library/style.min.css?ver=5.0.8' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://rivertonroll.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://rivertonroll.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://rivertonroll.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='WisdomTree Balanced Income Fund (NYSEARCA:WBAL) to Issue Dividend Increase &#8211; $0.23 Per Share' href='https://rivertonroll.com/news/2019/12/31/wisdomtree-balanced-income-fund-nysearcawbal-declares-dividend-increase-0-23-per-share-updated.html' />
<link rel='next' title='Applied Industrial Technologies (NYSE:AIT) Now Covered by Analysts at Robert W. Baird' href='https://rivertonroll.com/news/2019/12/31/robert-w-baird-begins-coverage-on-applied-industrial-technologies-nyseait-updated-updated.html' />
<meta name="generator" content="WordPress 5.0.8" />
<link rel="canonical" href="https://rivertonroll.com/news/2019/12/31/caribbean-investment-holdings-ltd-loncihl-announces-dividend-of-gbx-5-39-updated.html" />
<link rel='shortlink' href='https://rivertonroll.com/?p=3477091' />
<link rel="alternate" type="application/json+oembed" href="https://rivertonroll.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frivertonroll.com%2Fnews%2F2019%2F12%2F31%2Fcaribbean-investment-holdings-ltd-loncihl-announces-dividend-of-gbx-5-39-updated.html" />
<link rel="alternate" type="text/xml+oembed" href="https://rivertonroll.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frivertonroll.com%2Fnews%2F2019%2F12%2F31%2Fcaribbean-investment-holdings-ltd-loncihl-announces-dividend-of-gbx-5-39-updated.html&#038;format=xml" />
<link rel="amphtml" href="https://rivertonroll.com/news/2019/12/31/caribbean-investment-holdings-ltd-loncihl-announces-dividend-of-gbx-5-39-updated.html/amp" /><link rel="icon" href="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-logo-256-white-150x150.png" sizes="32x32" />
<link rel="icon" href="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-logo-256-white.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-logo-256-white.png" />
<meta name="msapplication-TileImage" content="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-logo-256-white.png" />

<!-- Start Meta Data -->

<title>Caribbean Investment Holdings Ltd (LON:CIHL) to Issue GBX 5.39 Dividend - Riverton Roll</title>


<meta name="description" content="Caribbean Investment Holdings Ltd (LON:CIHL) declared a dividend on Monday, December 23rd, Upcoming.Co.Uk reports. Stockholders of record on Thursday, January 2nd will be given a dividend of GBX 5.39 ($0.07) per share on Friday, January 24th. This represents a dividend yield of 28.37%. The ex-dividend date is Thursday, January 2nd. The official announcement can be [&hellip;]" />
<meta name="author" content="Rob Hiaasen">
<meta name="news_keywords" content="Caribbean Investment,LON:CIHL,CIHL,LON,Dividends" />
<meta name="keywords" content="Caribbean Investment,LON:CIHL,CIHL,LON,Dividends" />
<meta name="ticker" content="LON:CIHL" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@RatingsNetwork" />
<meta name="twitter:title" content="Caribbean Investment Holdings Ltd (LON:CIHL) to Issue GBX 5.39 Dividend"/>
<meta name="twitter:description" content="Caribbean Investment Holdings Ltd (LON:CIHL) declared a dividend on Monday, December 23rd, Upcoming.Co.Uk reports. Stockholders of record on Thursday, January 2nd will be given a dividend of GBX 5.39 ($0.07) per share on Friday, January 24th. This represents a dividend yield of 28.37%. The ex-dividend date is Thursday, January 2nd. The official announcement can be [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/generic-stocks.jpg" />

<!-- Open Graph Data -->
<meta property="og:title" content="Caribbean Investment Holdings Ltd (LON:CIHL) to Issue GBX 5.39 Dividend" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://rivertonroll.com/news/2019/12/31/caribbean-investment-holdings-ltd-loncihl-announces-dividend-of-gbx-5-39-updated.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/generic-stocks.jpg" />
<meta property="og:description" content="Caribbean Investment Holdings Ltd (LON:CIHL) declared a dividend on Monday, December 23rd, Upcoming.Co.Uk reports. Stockholders of record on Thursday, January 2nd will be given a dividend of GBX 5.39 ($0.07) per share on Friday, January 24th. This represents a dividend yield of 28.37%. The ex-dividend date is Thursday, January 2nd. The official announcement can be [&hellip;]" />
<meta property="og:site_name" content="Riverton Roll" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2019-12-31T00:40:57+0000" />
<meta property="article:modified_time" content="2019-12-31T00:40:57+0000" />
<meta property="article:tag" content="LON:CIHL" />
<meta property="article:tag" content="Caribbean Investment,LON:CIHL,CIHL,LON,Dividends" />
<meta property="article:section" content="Investment" />

<!-- Google meta is in the body-->


	<meta name="googlebot" content="unavailable_after: 2020-02-29T00:40:57+0000" />
<!-- End Meta Data -->

	
<script type='text/javascript'>var PopupAdChannel=''; </script>

  <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'rivertonroll.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "467d2940-348c-4e60-8aab-3f08a21baf03",
      safari_web_id: 'web.onesignal.auto.27841aa0-90c9-472e-b116-e68b5f82c9c6', 
      autoRegister: true,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
  </script>

  <script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
<!-- IMS header goes here -->
	
	<script type="text/javascript">
		var apntag = apntag || {};
		apntag.anq = apntag.anq || [];
		(function() {
			var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
			e.type = 'text/javascript';  e.async = true;
			e.src = '//acdn.adnxs.com/ast/ast.js';
			p.insertBefore(e, p.firstChild);
		})();

		
		apntag.anq.push(function() {
			apntag.setPageOpts({
				member: 6989
			});
		});

		apntag.anq.push(function() {

      		apntag.defineTag({
				tagId: 13685716,
				sizes: [[300,250]],
				keywords: {'position': ['RightRail_1']},
				targetId: 'RivertonRoll_ROS_RightRail_1'
			});

		apntag.anq.push(function() {
			apntag.loadTags();
		});
		});
		</script>
	
<script type="text/javascript">
(function() {
window.advBidxc = window.advBidxc || {};
window.advBidxc.startTime = new Date().getTime();
function loadScript(tagSrc) {
var scriptTag = document.createElement('script'),
placeTag = document.getElementsByTagName("script")[0];
scriptTag.type = 'text/javascript';
scriptTag.async = true;
scriptTag.src = tagSrc;
placeTag.parentNode.insertBefore(scriptTag, placeTag);
}
var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' +
window.location.hostname;
loadScript(mnSrc);
})();
</script>
	<!-- end IMS -->

	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>
	
	

		<!-- Gemini Tag -->
	<script type="application/javascript">(function(w,d,t,r,u){w[u]=w[u]||[];w[u].push({'projectId':'10000','properties':{'pixelId':'423827'}});var s=d.createElement(t);s.src=r;s.async=true;s.onload=s.onreadystatechange=function(){var y,rs=this.readyState,c=w[u];if(rs&&rs!="complete"&&rs!="loaded"){return}try{y=YAHOO.ywa.I13N.fireBeacon;w[u]=[];w[u].push=function(p){y([p])};y(c)}catch(e){}};var scr=d.getElementsByTagName(t)[0],par=scr.parentNode;par.insertBefore(s,scr)})(window,document,"script","https://s.yimg.com/wi/ytc.js","dotq");</script>

</head>

<body>

<!-- Start MarketBeat Modern Popup -->
	<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=52"></script>

	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Riverton Roll', 'rivertonroll.com', 'LON:CIHL', 'Caribbean Investment', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/generic-stocks.jpg');</script>
	<!-- End MarketBeat Modern Popup -->
	
<!-- One Signal Registration Code -->
<script type="text/javascript">
if(OneSignal.isPushNotificationsSupported())
{
    OneSignal.registerForPushNotifications();
}
</script>
<!-- End Registration Code -->

<header>
<div id="top-bar">
		<div class="width-limiter">
				<!-- top nav bar -->
				<nav class="navigation"><ul id="menu-header-menu" class="menu"><li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30"><a href="https://rivertonroll.com/about-us">About Us</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29"><a href="https://rivertonroll.com/contact-us">Contact Us</a></li>
<li id="menu-item-28" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28"><a href="https://rivertonroll.com/privacy-policy">Privacy Policy</a></li>
</ul></nav>		</div><!-- end: width-limiter in top-bar -->
	</div><!-- end: top-bar -->

	<div class="width-limiter add-padding"><!-- start: width-limiter with logo and space for alternate header unit -->
		<a class="logo-link" href="https://rivertonroll.com"><img id="logo" src="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-280-90-logo.png" alt="Riverton Roll logo"></a>

		<!----- Begin  header unit  ----->
		<div id="AlternateHeaderUnit">
<!-- Network Wide AdSense Unit - Header Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="5679141823" data-ad-format="horizontal" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
</div> 

<!-- End Header Unit-->
	</div> <!-- end: width-limiter with logo and space for alternate header unit -->

	<div id="menu">
		<div class="width-limiter" id="nav-main">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-main-menu" class="menu"><li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a href="https://rivertonroll.com/business">Business</a></li>
<li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://rivertonroll.com/entertainment">Entertainment</a></li>
<li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://rivertonroll.com/health-care">Health Care</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://rivertonroll.com/industry">Industry</a></li>
<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://rivertonroll.com/research">Research</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://rivertonroll.com/sports">Sports</a></li>
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://rivertonroll.com/world-news">World News</a></li>
</ul></nav>
			

				<form id="searchform" action="https://rivertonroll.com/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" placeholder="Search" />
						<input class="searchsubmit" type="submit" value="" />
					</div>
				</form><!-- end: searchform -->
		</div> <!-- end: width-limiter for menu -->

	</div> <!-- end: menu -->

</header> <!-- end: header -->
	<div class="width-limiter main-content">
		
<aside>
	
	<div>
		
<!-- Begin Dianomi Unit -->
<iframe width="336" height="670" scrolling="NO" src="//www.dianomi.com/smartads.epl?id=3355" style="width: 336px; max-width:100%; border: none; overflow: hidden;"></iframe>
<!-- End Dianomi Unit -->
	</div>

<div>
<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
	</div>
	
	<div>
<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
	</div>
	



<!-- OptIn Form -->
<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for Caribbean Investment</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for Caribbean Investment with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="Riverton Roll-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="LON:CIHL" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>
<!-- End Sidebar Registration -->

<!-- social media would go here -->
<!-- IMS unit -->
	<div id="RivertonRoll_ROS_RightRail_1" class="text-center">
			<script type="text/javascript">
			apntag.anq.push(function() {
				apntag.showTag('RivertonRoll_ROS_RightRail_1');
			});
			</script>
		</div>
<!-- end IMS unit -->

<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Recent Posts</h3>
            <ul>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/jungheinrich-etrjun3-given-a-20-00-price-target-at-deutsche-bank-2.html">Jungheinrich (ETR:JUN3) Given a &euro;20.00 Price Target at Deutsche Bank</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/deutsche-bank-analysts-give-hugo-boss-etrboss-a-48-00-price-target.html">Deutsche Bank Analysts Give Hugo Boss (ETR:BOSS) a &euro;48.00 Price Target</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/zalando-frazal-pt-set-at-55-00-by-warburg-research.html">Zalando (FRA:ZAL) PT Set at &euro;55.00 by Warburg Research</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/credit-suisse-group-analysts-give-diageo-londge-a-gbx-3570-price-target.html">Credit Suisse Group Analysts Give Diageo (LON:DGE) a GBX 3,570 Price Target</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/cts-eventim-ag-42-00-price-target-by-baader-bank-analysts.html">CTS Eventim AG &#038; Co KGaA (ETR:EVD) Given a &euro;42.00 Price Target by Baader Bank Analysts</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/wirecard-etrwdi-pt-set-at-270-00-by-hauck-aufhaeuser.html">Wirecard (ETR:WDI) PT Set at &euro;270.00 by Hauck &#038; Aufhaeuser</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/diageo-londge-pt-set-at-gbx-3600-by-jefferies-financial-group.html">Diageo (LON:DGE) PT Set at GBX 3,600 by Jefferies Financial Group</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/krones-etrkrn-pt-set-at-70-00-by-independent-research.html">Krones (ETR:KRN) PT Set at &euro;70.00 by Independent Research</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/rib-software-etrrib-given-a-21-00-price-target-at-kepler-capital-markets.html">RIB Software (ETR:RIB) Given a &euro;21.00 Price Target at Kepler Capital Markets</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/national-grid-lonng-given-a-gbx-980-price-target-at-deutsche-bank-2.html">National Grid (LON:NG) Given a GBX 980 Price Target at Deutsche Bank</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/imf-bentham-asximf-reaches-new-1-year-high-at-4-49.html">IMF Bentham (ASX:IMF) Reaches New 1-Year High at $4.49</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/psc-insurance-group-asxpsi-hits-new-52-week-high-at-3-13.html">PSC Insurance Group (ASX:PSI) Hits New 52-Week High at $3.13</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/airtel-africa-limited-lonaaf-insider-shravin-bharti-mittal-purchases-3700000-shares-of-stock.html">Airtel Africa Limited (LON:AAF) Insider Shravin Bharti Mittal Purchases 3,700,000 Shares of Stock</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/zenith-energy-ltd-lonzen-insider-andrea-cattaneo-acquires-125000-shares-of-stock.html">Zenith Energy Ltd (LON:ZEN) Insider Andrea Cattaneo Acquires 125,000 Shares of Stock</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/capital-regional-plc-loncal-insider-ian-krieger-sells-36876-shares.html">Capital &#038; Regional plc (LON:CAL) Insider Ian Krieger Sells 36,876 Shares</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/tesco-plc-lontsco-insider-dave-lewis-buys-54-shares-of-stock.html">Tesco PLC (LON:TSCO) Insider Dave Lewis Buys 54 Shares of Stock</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/yocoin-yoc-price-tops-0-0006-on-exchanges.html">Yocoin (YOC) Price Tops $0.0006 on Exchanges</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/bitusd-bitusd-hits-one-day-trading-volume-of-22-00.html">bitUSD (BITUSD) Hits One Day Trading Volume of $22.00</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/nucleus-vision-ncash-24-hour-trading-volume-hits-217226-00.html">Nucleus Vision (NCASH) 24-Hour Trading Volume Hits $217,226.00</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2019/12/31/jibrel-network-jnt-trading-down-4-7-this-week.html">Jibrel Network (JNT) Trading Down 4.7% This Week</a></li>
                        </ul>
        </div>  
<!-- end recent posts -->

</aside><!--end #sidebar-->
		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://rivertonroll.com/news/2019/12/31/caribbean-investment-holdings-ltd-loncihl-announces-dividend-of-gbx-5-39-updated.html" />
				<div class="page-title">
				<h1 itemprop="headline">Caribbean Investment Holdings Ltd (LON:CIHL) to Issue GBX 5.39 Dividend</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://rivertonroll.com/news/author/xrob" title="Posts by Rob Hiaasen" rel="author">Rob Hiaasen</a></span></span> on <span itemprop="datePublished dateModified" content="2019-12-31T00:40:57+0000">Dec 31st, 2019</span> 
				</p><!--end .postmeta-->

				<div style="clear:both"></div>
				</div>
				<!--sse-->
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					
					<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/generic-stocks.jpg" alt="Caribbean Investment logo" title="Caribbean Investment logo" class="companylogo" /><strong>Caribbean Investment Holdings Ltd</strong> (LON:CIHL) declared a  dividend on Monday, December 23rd, <a href='https://www.dividenddata.co.uk/'>Upcoming.Co.Uk</a> reports. Stockholders of record on Thursday, January 2nd will be given a dividend of GBX 5.39 ($0.07) per share on Friday, January 24th. This represents a dividend yield of 28.37%. The ex-dividend date is Thursday, January 2nd. The official announcement can be viewed at <a href='http://www.londonstockexchange.com/exchange/news/market-news/market-news-detail/CIHL/14360599.html' target='_blank'>this link</a>. </p>
<p><a href='https://www.marketbeat.com/stocks/LON/CIHL/dividend/' target='_blank'>LON:CIHL</a> traded down GBX 1 ($0.01) during midday trading on Monday, reaching GBX 31 ($0.41). The stock had a trading volume of 435,331 shares, compared to its average volume of 7,803. Caribbean Investment has a 1-year low of GBX 13.12 ($0.17) and a 1-year high of GBX 19.56 ($0.26). The firm&#8217;s fifty day simple moving average is GBX 18.30 and its 200-day simple moving average is GBX 17.01. The stock has a market capitalization of $32.13 million and a P/E ratio of 2.87. </p>


<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Riverton Roll"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="LON:CIHL" />    <label for="InPostRegistrationEmail">Get <b>Caribbean Investment</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></input></div>
</form>
<div id="ShowSuggestionInPost"></div>
		


<p><strong>About Caribbean Investment</strong></p>

<div style="float:left;margin:5px 10px 10px 0;width:340px;">
<!-- Network Wide AdSense Unit - In-Post Position -->
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9254111670"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
</div>
				 

					<p>Caribbean Investment Holdings Limited, through its subsidiaries, provides banking and financial services in Belize and internationally. The company offers savings accounts, non-interest bearing and interest bearing checking accounts, merchant accounts, and term deposits; and lending services, including overdrafts, lines of credit, and secured mortgage loans for personal, residential, or commercial purposes.</p>
<p>Read More: <a href='https://www.marketbeat.com/financial-terms/growth-stocks-what-they-are/'>Growth Stocks</a><!--ViewCount:type=d&id=125882--></p>
<p><!--Keyword: Caribbean Investment,LON:CIHL,CIHL,LON,Dividends--><!--Refreshed1--></p>

			 	<!-- end inline unit -->

				<!-- end main text -->

				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->


<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for Caribbean Investment Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Caribbean Investment and related companies with <a href="/daily-email-updates-basic/?symbol=LON:CIHL&c=Caribbean+Investment" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="Riverton Roll-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="LON:CIHL" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->


				</div> <!-- end: entry -->
				<!--/sse-->
				 
				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=300&h=300&zc=1&src=https://www.marketbeat.com/logos/generic-stocks.jpg" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-280-90-logo.png">
 						<meta itemprop="height" content="90">
						 <meta itemprop="width" content="280">
					 </div>
					<meta itemprop="name" content="Riverton Roll"/>
					<meta itemprop="url" content="https://rivertonroll.com" />
 				</div>
				<!-- end article metadata -->

			</article>

		<!-- IMS below post -->
		<div id="rivertonroll_ros_belowpost_1"></div><br><br>
<!-- end IMS below post -->
		

			<!-- start Dianomi – sponsored content -->
			<iframe style="max-width:100%" width="654" height="787" scrolling="no" src="//www.dianomi.com/smartads.epl?id=2341"></iframe>
			<!-- end sponsored content -->

			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://rivertonroll.com/news/2019/12/31/wisdomtree-balanced-income-fund-nysearcawbal-declares-dividend-increase-0-23-per-share-updated.html" rel="prev"><div class="previous"><span class="left">&nbsp;&laquo;&nbsp;</span><h4>PREVIOUS</h4><p>WisdomTree Balanced Income Fund (NYSEARCA:WBAL) to Issue Dividend Increase &#8211; $0.23 Per Share</p></div></a>				<a href="https://rivertonroll.com/news/2019/12/31/robert-w-baird-begins-coverage-on-applied-industrial-technologies-nyseait-updated-updated.html" rel="next"><div class="next"><span class="right">&nbsp;&raquo;&nbsp;</span><h4>NEXT</h4><p>Applied Industrial Technologies (NYSE:AIT) Now Covered by Analysts at Robert W. Baird</p></div></a>			
			</nav><!-- end previous and next article links -->

			<div id="latest-news">
				<h2>More Articles</h2>
			 				 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/jungheinrich-ag-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Jungheinrich  Given a &euro;20.00 Price Target at Deutsche Bank" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2019/12/31/jungheinrich-etrjun3-given-a-20-00-price-target-at-deutsche-bank-2.html" rel="bookmark">Jungheinrich  Given a &euro;20.00 Price Target at Deutsche Bank</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/hugo-boss-ag-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Deutsche Bank Analysts Give Hugo Boss  a &euro;48.00 Price Target" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2019/12/31/deutsche-bank-analysts-give-hugo-boss-etrboss-a-48-00-price-target.html" rel="bookmark">Deutsche Bank Analysts Give Hugo Boss  a &euro;48.00 Price Target</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/zalando-se-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Zalando  PT Set at &euro;55.00 by Warburg Research" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2019/12/31/zalando-frazal-pt-set-at-55-00-by-warburg-research.html" rel="bookmark">Zalando  PT Set at &euro;55.00 by Warburg Research</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/diageo-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Credit Suisse Group Analysts Give Diageo  a GBX 3,570 Price Target" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2019/12/31/credit-suisse-group-analysts-give-diageo-londge-a-gbx-3570-price-target.html" rel="bookmark">Credit Suisse Group Analysts Give Diageo  a GBX 3,570 Price Target</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/cts-eventim-ag--co-kgaa-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="CTS Eventim AG &#038; Co KGaA  Given a &euro;42.00 Price Target by Baader Bank Analysts" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2019/12/31/cts-eventim-ag-42-00-price-target-by-baader-bank-analysts.html" rel="bookmark">CTS Eventim AG &#038; Co KGaA  Given a &euro;42.00 Price Target by Baader Bank Analysts</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/wirecard-ag-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Wirecard  PT Set at &euro;270.00 by Hauck &#038; Aufhaeuser" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2019/12/31/wirecard-etrwdi-pt-set-at-270-00-by-hauck-aufhaeuser.html" rel="bookmark">Wirecard  PT Set at &euro;270.00 by Hauck &#038; Aufhaeuser</a>
				</div>
	 						</div><!-- end latest news -->

<!-- second ad spot -->


<br>
	</main> <!-- end main -->

	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<footer class="full-width">
			<div class="width-limiter">

				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a href="https://rivertonroll.com/business">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://rivertonroll.com/entertainment">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://rivertonroll.com/health-care">Health Care</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://rivertonroll.com/industry">Industry</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://rivertonroll.com/research">Research</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://rivertonroll.com/sports">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://rivertonroll.com/world-news">World News</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2006-2019 <a href="https://rivertonroll.com">Riverton Roll</a>
					</span>
				</div><!-- end #footer-info -->

			</div>	
		</footer>
		<script type='text/javascript' src='https://rivertonroll.com/wp-includes/js/wp-embed.min.js?ver=5.0.8'></script>
	
<!-- Start of StatCounter Code for Riverton Roll -->
<script type="text/javascript">
var sc_project=11450080; 
var sc_invisible=1; 
var sc_security="bc674887"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script><noscript><img class="statcounter" src="//c.statcounter.com/11450080/0/bc674887/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for Riverton Roll -->

<!-- Start of StatCounter Code for Finance Articles -->
<script type="text/javascript">
	var sc_project=9021069; 
	var sc_invisible=1; 
	var sc_security="fdde5482"; 
	var sc_https=1; 
	document.write("<sc"+"ript type='text/javascript' src='https://www.statcounter.com/counter/counter.js'></" + "script>");
</script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/"></noscript>
<!-- End of StatCounter Code for Finance Articles -->

<!-- Start of StatCounter Code for Group 2 News Sites -->
<script type="text/javascript">
var sc_project=10694665; 
var sc_invisible=1; 
var sc_security="475eacb4"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
document.write("<sc"+"ript type='text/javascript' src='" + scJsHost+ "statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><img class="statcounter" src="https://c.statcounter.com/10694665/0/475eacb4/1/"></noscript>
<!-- End of StatCounter Code for Group 2 News Sites -->

<!-- Begin Social Sharing -->
		<div style="top:25%;left:0;position:fixed;width:50px;z-index:20;box-sizing:content-box;" class="mobile-hide">
	<div style="background-color:#305891;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.facebook.com/sharer/sharer.php?u=https://rivertonroll.com/news/2019/12/31/caribbean-investment-holdings-ltd-loncihl-announces-dividend-of-gbx-5-39-updated.html" target="_blank"><img src="/images/social-fb.png" style="margin:0;padding:0;" alt="share news on Facebook"></a></div>
	<div style="background-color:#2CA8D2;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://twitter.com/intent/tweet?text=Caribbean Investment Holdings Ltd $LON:CIHL to Issue GBX 5.39 Dividend https://rivertonroll.com/news/2019/12/31/caribbean-investment-holdings-ltd-loncihl-announces-dividend-of-gbx-5-39-updated.html" target="_blank"><img src="/images/social-tw.png" style="margin:0;padding:0;" alt="tweet this investment news"></a></div>
	<div style="background-color:#007BB6;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.linkedin.com/cws/share?mini=true&url=https://rivertonroll.com/news/2019/12/31/caribbean-investment-holdings-ltd-loncihl-announces-dividend-of-gbx-5-39-updated.html" target="_blank"><img src="/images/social-in.png" style="margin:0;padding:0;" alt="share on linkedin"></a></div>
	<div style="background-color:#89120a;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://stocktwits.com/widgets/share?via=AnalystRatingsNetwork&body=Caribbean Investment Holdings Ltd $LON:CIHL to Issue GBX 5.39 Dividend https://rivertonroll.com/news/2019/12/31/caribbean-investment-holdings-ltd-loncihl-announces-dividend-of-gbx-5-39-updated.html" target="_blank"><img src="/images/social-st.png" style="margin:0;padding:0;box-sizing:content-box;" alt="share on StockTwits"></a></div>
	<div style="background-color:#FF1A00;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.reddit.com/submit?url=https://rivertonroll.com/news/2019/12/31/caribbean-investment-holdings-ltd-loncihl-announces-dividend-of-gbx-5-39-updated.html&title=Caribbean Investment Holdings Ltd (LON:CIHL) to Issue GBX 5.39 Dividend" target="_blank"><img src="/images/social-reddit.png" style="margin:0;padding:0;" alt="share on reddit"></a></div>
	</div>
	<!-- End Social Sharing -->

<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?type=d&id=125882&domain=rivertonroll.com&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->


<!-- Start of StatCounter Code for Updated Articles -->
<script type="text/javascript">
var sc_project=11343649; var sc_invisible=1;  var sc_security="4ff2a83d"; var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
document.write("<sc"+"ript type='text/javascript' src='" + scJsHost+ "statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><img class="statcounter" src="//c.statcounter.com/11297244/0/7b79caf5/1/"></noscript>
<!-- End of StatCounter Code for Updated Articles -->

<!-- Default Statcounter Code for Active GN Sites -->
<script type="text/javascript">
var sc_project=12038725; 
var sc_invisible=1; 
var sc_security="4f9c00a6"; 
var sc_https=1; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><div class="statcounter"><a title="Web Analytics" href="https://statcounter.com/" target="_blank"><img class="statcounter" src="https://c.statcounter.com/12038725/0/4f9c00a6/1/" alt="Web Analytics"></a></div></noscript>
<!-- End of Statcounter Code -->

	</body>

</html>