<!doctype html>
<html lang="en">

<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
 <meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
 <meta name="google-site-verification" content="4GrvUcextHKMFj91p1HDoOkOw9cvgqpM9_PmZtIoSDE" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="norton-safeweb-site-verification" content="4-8q940c68tts8mkrawweyw-fb0a-n0z-hr50v9pgp3alu7yrtpnma8cbusdizeq5y9-i8ztd697gah1hnnckhcmfuc99-gljisqjinmyn7xy8teaglw2fafhn5s0zue" />
<meta name="viewport" content="width=1040">

<!-- Escape from Frames  -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script>
<link href="https://fonts.googleapis.com/css?family=Roboto" rel="stylesheet">
<link rel="stylesheet" href="https://rivertonroll.com/wp-content/themes/alambre/style.css?1533069294" type="text/css" media="screen, projection" />

<link href="https://rivertonroll.com/feed" rel="alternate" title="Riverton Roll RSS Feed" type="application/rss+xml" />
<link href="https://rivertonroll.com/feed/atom" rel="alternate" title="Riverton Roll Atom Feed" type="application/atom+xml" />
<link href="https://rivertonroll.com/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://rivertonroll.com/wp-includes/css/dist/block-library/style.min.css?ver=5.0.8' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://rivertonroll.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://rivertonroll.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://rivertonroll.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='iShares Russell 1000 ETF (NYSEARCA:IWB) Shares Bought by Huntington National Bank' href='https://rivertonroll.com/news/2020/01/19/ishares-russell-1000-etf-nysearcaiwb-shares-bought-by-huntington-national-bank.html' />
<link rel='next' title='First National Bank of Omaha Boosts Holdings in Old National Bancorp (NASDAQ:ONB)' href='https://rivertonroll.com/news/2020/01/19/first-national-bank-of-omaha-boosts-holdings-in-old-national-bancorp-nasdaqonb.html' />
<meta name="generator" content="WordPress 5.0.8" />
<link rel="canonical" href="https://rivertonroll.com/news/2020/01/19/meag-munich-ergo-kapitalanlagegesellschaft-mbh-makes-new-investment-in-fortis-inc-nysefts.html" />
<link rel='shortlink' href='https://rivertonroll.com/?p=3674383' />
<link rel="alternate" type="application/json+oembed" href="https://rivertonroll.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frivertonroll.com%2Fnews%2F2020%2F01%2F19%2Fmeag-munich-ergo-kapitalanlagegesellschaft-mbh-makes-new-investment-in-fortis-inc-nysefts.html" />
<link rel="alternate" type="text/xml+oembed" href="https://rivertonroll.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frivertonroll.com%2Fnews%2F2020%2F01%2F19%2Fmeag-munich-ergo-kapitalanlagegesellschaft-mbh-makes-new-investment-in-fortis-inc-nysefts.html&#038;format=xml" />
<link rel="amphtml" href="https://rivertonroll.com/news/2020/01/19/meag-munich-ergo-kapitalanlagegesellschaft-mbh-makes-new-investment-in-fortis-inc-nysefts.html/amp" /><link rel="icon" href="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-logo-256-white-150x150.png" sizes="32x32" />
<link rel="icon" href="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-logo-256-white.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-logo-256-white.png" />
<meta name="msapplication-TileImage" content="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-logo-256-white.png" />

<!-- Start Meta Data -->

<title>Meag Munich Ergo Kapitalanlagegesellschaft MBH Makes New Investment in Fortis Inc (NYSE:FTS) - Riverton Roll</title>


<meta name="description" content="Meag Munich Ergo Kapitalanlagegesellschaft MBH bought a new position in shares of Fortis Inc (NYSE:FTS) during the fourth quarter, according to the company in its most recent filing with the Securities and Exchange Commission. The institutional investor bought 22,076 shares of the utilities provider&#8217;s stock, valued at approximately $913,000. Several other hedge funds have also [&hellip;]" />
<meta name="author" content="Steve Reilly">
<meta name="news_keywords" content="Fortis,NYSE:FTS,FTS,Utilitie,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="keywords" content="Fortis,NYSE:FTS,FTS,Utilitie,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="ticker" content="NYSE:FTS" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@RatingsNetwork" />
<meta name="twitter:title" content="Meag Munich Ergo Kapitalanlagegesellschaft MBH Makes New Investment in Fortis Inc (NYSE:FTS)"/>
<meta name="twitter:description" content="Meag Munich Ergo Kapitalanlagegesellschaft MBH bought a new position in shares of Fortis Inc (NYSE:FTS) during the fourth quarter, according to the company in its most recent filing with the Securities and Exchange Commission. The institutional investor bought 22,076 shares of the utilities provider&#8217;s stock, valued at approximately $913,000. Several other hedge funds have also [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/fortis-inc-logo.jpg" />

<!-- Open Graph Data -->
<meta property="og:title" content="Meag Munich Ergo Kapitalanlagegesellschaft MBH Makes New Investment in Fortis Inc (NYSE:FTS)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://rivertonroll.com/news/2020/01/19/meag-munich-ergo-kapitalanlagegesellschaft-mbh-makes-new-investment-in-fortis-inc-nysefts.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/fortis-inc-logo.jpg" />
<meta property="og:description" content="Meag Munich Ergo Kapitalanlagegesellschaft MBH bought a new position in shares of Fortis Inc (NYSE:FTS) during the fourth quarter, according to the company in its most recent filing with the Securities and Exchange Commission. The institutional investor bought 22,076 shares of the utilities provider&#8217;s stock, valued at approximately $913,000. Several other hedge funds have also [&hellip;]" />
<meta property="og:site_name" content="Riverton Roll" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2020-01-19T13:40:44+0000" />
<meta property="article:modified_time" content="2020-01-19T13:40:44+0000" />
<meta property="article:tag" content="NYSE:FTS" />
<meta property="article:tag" content="Fortis,NYSE:FTS,FTS,Utilitie,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta property="article:section" content="Investment" />

<!-- Google meta is in the body-->


	<meta name="googlebot" content="unavailable_after: 2020-03-19T13:40:44+0000" />
<!-- End Meta Data -->

	
<script type='text/javascript'>var PopupAdChannel=''; </script>

  <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'rivertonroll.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "467d2940-348c-4e60-8aab-3f08a21baf03",
      safari_web_id: 'web.onesignal.auto.27841aa0-90c9-472e-b116-e68b5f82c9c6', 
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
	if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||(navigator.userAgent.toLowerCase().indexOf('safari') > -1)){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}	  
  </script>

  <script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
<!-- IMS header goes here -->
	
	<script type="text/javascript">
		var apntag = apntag || {};
		apntag.anq = apntag.anq || [];
		(function() {
			var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
			e.type = 'text/javascript';  e.async = true;
			e.src = '//acdn.adnxs.com/ast/ast.js';
			p.insertBefore(e, p.firstChild);
		})();

		
		apntag.anq.push(function() {
			apntag.setPageOpts({
				member: 6989
			});
		});

		apntag.anq.push(function() {

      		apntag.defineTag({
				tagId: 13685716,
				sizes: [[300,250]],
				keywords: {'position': ['RightRail_1']},
				targetId: 'RivertonRoll_ROS_RightRail_1'
			});

		apntag.anq.push(function() {
			apntag.loadTags();
		});
		});
		</script>
	
<script type="text/javascript">
(function() {
window.advBidxc = window.advBidxc || {};
window.advBidxc.startTime = new Date().getTime();
function loadScript(tagSrc) {
var scriptTag = document.createElement('script'),
placeTag = document.getElementsByTagName("script")[0];
scriptTag.type = 'text/javascript';
scriptTag.async = true;
scriptTag.src = tagSrc;
placeTag.parentNode.insertBefore(scriptTag, placeTag);
}
var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' +
window.location.hostname;
loadScript(mnSrc);
})();
</script>
	<!-- end IMS -->

	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>
	
	

		<!-- Gemini Tag -->
	<script type="application/javascript">(function(w,d,t,r,u){w[u]=w[u]||[];w[u].push({'projectId':'10000','properties':{'pixelId':'423827'}});var s=d.createElement(t);s.src=r;s.async=true;s.onload=s.onreadystatechange=function(){var y,rs=this.readyState,c=w[u];if(rs&&rs!="complete"&&rs!="loaded"){return}try{y=YAHOO.ywa.I13N.fireBeacon;w[u]=[];w[u].push=function(p){y([p])};y(c)}catch(e){}};var scr=d.getElementsByTagName(t)[0],par=scr.parentNode;par.insertBefore(s,scr)})(window,document,"script","https://s.yimg.com/wi/ytc.js","dotq");</script>

</head>

<body>

<!-- Start MarketBeat Modern Popup -->
	<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=52"></script>

	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Riverton Roll', 'rivertonroll.com', 'NYSE:FTS', 'Fortis', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/fortis-inc-logo.jpg');</script>
	<!-- End MarketBeat Modern Popup -->
	
<!-- One Signal Registration Code -->
<script type="text/javascript">
if(OneSignal.isPushNotificationsSupported())
{
    OneSignal.registerForPushNotifications();
}
</script>
<!-- End Registration Code -->

<header>
<div id="top-bar">
		<div class="width-limiter">
				<!-- top nav bar -->
				<nav class="navigation"><ul id="menu-header-menu" class="menu"><li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30"><a href="https://rivertonroll.com/about-us">About Us</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29"><a href="https://rivertonroll.com/contact-us">Contact Us</a></li>
<li id="menu-item-28" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28"><a href="https://rivertonroll.com/privacy-policy">Privacy Policy</a></li>
</ul></nav>		</div><!-- end: width-limiter in top-bar -->
	</div><!-- end: top-bar -->

	<div class="width-limiter add-padding"><!-- start: width-limiter with logo and space for alternate header unit -->
		<a class="logo-link" href="https://rivertonroll.com"><img id="logo" src="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-280-90-logo.png" alt="Riverton Roll logo"></a>

		<!----- Begin  header unit  ----->
		<div id="AlternateHeaderUnit">
<!-- Network Wide AdSense Unit - Header Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="5679141823" data-ad-format="horizontal" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
</div> 

<!-- End Header Unit-->
	</div> <!-- end: width-limiter with logo and space for alternate header unit -->

	<div id="menu">
		<div class="width-limiter" id="nav-main">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-main-menu" class="menu"><li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a href="https://rivertonroll.com/business">Business</a></li>
<li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://rivertonroll.com/entertainment">Entertainment</a></li>
<li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://rivertonroll.com/health-care">Health Care</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://rivertonroll.com/industry">Industry</a></li>
<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://rivertonroll.com/research">Research</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://rivertonroll.com/sports">Sports</a></li>
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://rivertonroll.com/world-news">World News</a></li>
</ul></nav>
			

				<form id="searchform" action="https://rivertonroll.com/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" placeholder="Search" />
						<input class="searchsubmit" type="submit" value="" />
					</div>
				</form><!-- end: searchform -->
		</div> <!-- end: width-limiter for menu -->

	</div> <!-- end: menu -->

</header> <!-- end: header -->
	<div class="width-limiter main-content">
		
<aside>
	
	<div>
		
<!-- Begin Dianomi Unit -->
<iframe width="336" height="670" scrolling="NO" src="//www.dianomi.com/smartads.epl?id=3355" style="width: 336px; max-width:100%; border: none; overflow: hidden;"></iframe>
<!-- End Dianomi Unit -->
	</div>

<div>
<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
	</div>
	
	<div>
<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
	</div>
	



<!-- OptIn Form -->
<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for Fortis</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for Fortis with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="Riverton Roll-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:FTS" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>
<!-- End Sidebar Registration -->

<!-- social media would go here -->
<!-- IMS unit -->
	<div id="RivertonRoll_ROS_RightRail_1" class="text-center">
			<script type="text/javascript">
			apntag.anq.push(function() {
				apntag.showTag('RivertonRoll_ROS_RightRail_1');
			});
			</script>
		</div>
<!-- end IMS unit -->

<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Recent Posts</h3>
            <ul>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/zacks-analysts-expect-stitch-fix-inc-nasdaqsfix-to-post-0-06-eps.html">Zacks: Analysts Expect Stitch Fix Inc (NASDAQ:SFIX) to Post $0.06 EPS</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/zeke-capital-advisors-llc-sells-146-shares-of-progressive-corp-nysepgr.html">Zeke Capital Advisors LLC Sells 146 Shares of Progressive Corp (NYSE:PGR)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/alpha-cubed-investments-llc-grows-stake-in-eversource-energy-nysees.html">Alpha Cubed Investments LLC Grows Stake in Eversource Energy (NYSE:ES)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/citigroup-lowers-phillips-66-nysepsx-price-target-to-128-00.html">Citigroup Lowers Phillips 66 (NYSE:PSX) Price Target to $128.00</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/vodafone-groups-vod-overweight-rating-reiterated-at-barclays.html">Vodafone Group&#8217;s (VOD) Overweight Rating Reiterated at Barclays</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/workspace-group-lonwkp-earns-hold-rating-from-peel-hunt.html">Workspace Group (LON:WKP) Earns Hold Rating from Peel Hunt</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/whitbreads-wtb-hold-rating-reiterated-at-shore-capital.html">Whitbread&#8217;s (WTB) &#8220;Hold&#8221; Rating Reiterated at Shore Capital</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/wpps-wpp-buy-rating-reiterated-at-ubs-group.html">WPP&#8217;s (WPP) &#8220;Buy&#8221; Rating Reiterated at UBS Group</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/ubs-group-reaffirms-neutral-rating-for-mg-lonvty.html">UBS Group Reaffirms Neutral Rating for M&#038;G (LON:VTY)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/whitbreads-wtb-buy-rating-reiterated-at-peel-hunt.html">Whitbread&#8217;s (WTB) Buy Rating Reiterated at Peel Hunt</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/talktalk-telecom-group-lontalk-coverage-initiated-at-berenberg-bank.html">Talktalk Telecom Group (LON:TALK) Coverage Initiated at Berenberg Bank</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/mgs-vty-buy-rating-reaffirmed-at-peel-hunt.html">M&#038;G&#8217;s (VTY) &#8220;Buy&#8221; Rating Reaffirmed at Peel Hunt</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/tullow-oil-lontlw-cut-to-equal-weight-at-barclays.html">Tullow Oil (LON:TLW) Cut to &#8220;Equal weight&#8221; at Barclays</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/ubs-group-downgrades-william-hill-lonwmh-to-neutral.html">UBS Group Downgrades William Hill (LON:WMH) to Neutral</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/liberum-capital-reaffirms-buy-rating-for-workspace-group-lonwkp.html">Liberum Capital Reaffirms &#8220;Buy&#8221; Rating for Workspace Group (LON:WKP)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/goldman-sachs-group-initiates-coverage-on-tui-lontui.html">Goldman Sachs Group Initiates Coverage on TUI (LON:TUI)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/euno-euno-market-capitalization-achieves-109293-00.html">EUNO (EUNO) Market Capitalization Achieves $109,293.00</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/mallcoin-trading-up-7-5-over-last-week-mlc.html">Mallcoin Trading Up 7.5% Over Last Week (MLC)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/sentinel-chain-senc-market-capitalization-reaches-288951-00.html">Sentinel Chain (SENC) Market Capitalization Reaches $288,951.00</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/01/19/more-coin-more-achieves-market-capitalization-of-62027-00.html">More Coin (MORE) Achieves Market Capitalization of $62,027.00</a></li>
                        </ul>
        </div>  
<!-- end recent posts -->

</aside><!--end #sidebar-->
		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://rivertonroll.com/news/2020/01/19/meag-munich-ergo-kapitalanlagegesellschaft-mbh-makes-new-investment-in-fortis-inc-nysefts.html" />
				<div class="page-title">
				<h1 itemprop="headline">Meag Munich Ergo Kapitalanlagegesellschaft MBH Makes New Investment in Fortis Inc (NYSE:FTS)</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://rivertonroll.com/news/author/xsteve" title="Posts by Steve Reilly" rel="author">Steve Reilly</a></span></span> on <span itemprop="datePublished dateModified" content="2020-01-19T13:40:44+0000">Jan 19th, 2020</span> 
				</p><!--end .postmeta-->

				<div style="clear:both"></div>
				</div>
				<!--sse-->
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					
					<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/fortis-inc-logo.jpg" alt="Fortis logo" title="Fortis logo" class="companylogo" />Meag Munich Ergo Kapitalanlagegesellschaft MBH bought a new position in shares of  Fortis Inc (NYSE:FTS) during the fourth quarter, according to the company in its most recent filing with the Securities and Exchange Commission. The institutional investor  bought 22,076 shares of the utilities provider&#8217;s stock, valued at approximately $913,000. </p>
<p>Several other hedge funds have also recently bought and sold shares of FTS. Addenda Capital Inc. purchased a new position in shares of  Fortis during the 3rd quarter worth approximately $30,563,000.  Alberta Investment Management Corp grew its stake in shares of  Fortis by 67.7% in the 3rd quarter. Alberta Investment Management Corp now owns 1,635,600 shares of the utilities provider&#8217;s stock worth $69,192,000 after buying an additional 660,000 shares during the last quarter.  Vanguard Group Inc. grew its stake in shares of  Fortis by 3.3% in the 2nd quarter. Vanguard Group Inc. now owns 12,410,114 shares of the utilities provider&#8217;s stock worth $489,828,000 after buying an additional 398,352 shares during the last quarter.  Strs Ohio purchased a new stake in shares of  Fortis in the 3rd quarter worth approximately $16,375,000.  Finally, Prudential PLC grew its stake in shares of  Fortis by 1,148.4% in the 2nd quarter. Prudential PLC now owns 359,838 shares of the utilities provider&#8217;s stock worth $14,267,000 after buying an additional 331,014 shares during the last quarter. Hedge funds and other institutional investors own  49.49% of the company&#8217;s stock. </p>


<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Riverton Roll"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:FTS" />    <label for="InPostRegistrationEmail">Get <b>Fortis</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></input></div>
</form>
<div id="ShowSuggestionInPost"></div>
		


<p><a href='https://www.marketbeat.com/stocks/NYSE/FTS/sec-filings/' target='_blank'>Fortis stock</a> opened at $43.25 on Friday. The company has a quick ratio of 0.46, a current ratio of 0.56 and a debt-to-equity ratio of 1.32. The company has a market capitalization of $19.77 billion, a P/E ratio of 21.41, a PEG ratio of 3.75 and a beta of 0.13. The stock&#8217;s 50 day moving average is $41.03 and its 200 day moving average is $40.92. Fortis Inc has a twelve month low of $34.43 and a twelve month high of $43.32. </p>

<div style="float:left;margin:5px 10px 10px 0;width:340px;">
<!-- Network Wide AdSense Unit - In-Post Position -->
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9254111670"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
</div>
				 

					<p>Fortis (NYSE:FTS) last issued its earnings results on Friday, November 1st. The utilities provider reported $0.50 EPS for the quarter, beating the consensus estimate of $0.49 by $0.01. Fortis had a return on equity of 6.75% and a net margin of 12.72%. The business had revenue of $1.55 billion for the quarter, compared to the consensus estimate of $1.59 billion. During the same period last year, the business posted $0.65 EPS.  As a group, equities analysts expect that  Fortis Inc will post 1.95 EPS for the current year. </p>
<p>Several analysts recently weighed in on FTS shares. CIBC upgraded Fortis from a &#8220;neutral&#8221; rating to an &#8220;outperform&#8221; rating in a research note on Tuesday, December 3rd. Scotiabank upgraded Fortis from a &#8220;sector perform&#8221; rating to an &#8220;outperform&#8221; rating in a research note on Wednesday, December 4th. <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?Zacks=1'>Zacks Investment Research</a> downgraded Fortis from a &#8220;hold&#8221; rating to a &#8220;sell&#8221; rating in a research note on Monday, January 13th. TheStreet downgraded Fortis from a &#8220;b-&#8221; rating to a &#8220;c+&#8221; rating in a research note on Monday, November 11th. Finally, Bank of America downgraded Fortis from a &#8220;buy&#8221; rating to a &#8220;neutral&#8221; rating in a research note on Thursday, December 5th. Two analysts have rated the stock with a sell rating, seven have given a hold rating and six have given a buy rating to the company. The company currently has an average rating of &#8220;Hold&#8221; and an average price target of $55.63.</p>
<p><strong>Fortis Profile</strong></p>
<p>Fortis Inc operates as an electric and gas utility company in Canada, the United States, and the Caribbean. It generates, transmits, and distributes electricity to approximately 425,000 retail customers in southeastern Arizona; and 97,000 retail customers in Arizona&#x27;s Mohave and Santa Cruz counties with an aggregate capacity of 3,377 MW (MW), including 57 MW of solar capacity.</p>
<p>See Also: <a href='https://www.marketbeat.com/financial-terms/what-is-a-support-level/'>What is a support level?</a><!--ViewCount:ArticleHistoryID=46012072&PostDate=2020-1-19&type=f&id=6365080--></p>
<p style='text-align:center'><img src='https://www.marketbeat.com/scripts/SECFilingChart.ashx?Prefix=NYSE&#038;Symbol=FTS' alt='Institutional Ownership by Quarter for Fortis (NYSE:FTS)' title='Institutional Ownership by Quarter for Fortis (NYSE:FTS)' /></p>
<p><!--Keyword: Fortis,NYSE:FTS,FTS,Utilitie,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings--><!--Ratings:3,13,NYSE:FTS--></p>

			 	<!-- end inline unit -->

				<!-- end main text -->

				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->


<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for Fortis Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Fortis and related companies with <a href="/daily-email-updates-basic/?symbol=NYSE:FTS&c=Fortis" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="Riverton Roll-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:FTS" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->


				</div> <!-- end: entry -->
				<!--/sse-->
				 
				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=300&h=300&zc=1&src=https://www.marketbeat.com/logos/fortis-inc-logo.jpg" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-280-90-logo.png">
 						<meta itemprop="height" content="90">
						 <meta itemprop="width" content="280">
					 </div>
					<meta itemprop="name" content="Riverton Roll"/>
					<meta itemprop="url" content="https://rivertonroll.com" />
 				</div>
				<!-- end article metadata -->

			</article>

		<!-- IMS below post -->
		<div id="rivertonroll_ros_belowpost_1"></div><br><br>
<!-- end IMS below post -->
		

			<!-- start Dianomi – sponsored content -->
			<iframe style="max-width:100%" width="654" height="787" scrolling="no" src="//www.dianomi.com/smartads.epl?id=2341"></iframe>
			<!-- end sponsored content -->

			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://rivertonroll.com/news/2020/01/19/ishares-russell-1000-etf-nysearcaiwb-shares-bought-by-huntington-national-bank.html" rel="prev"><div class="previous"><span class="left">&nbsp;&laquo;&nbsp;</span><h4>PREVIOUS</h4><p>iShares Russell 1000 ETF (NYSEARCA:IWB) Shares Bought by Huntington National Bank</p></div></a>				<a href="https://rivertonroll.com/news/2020/01/19/first-national-bank-of-omaha-boosts-holdings-in-old-national-bancorp-nasdaqonb.html" rel="next"><div class="next"><span class="right">&nbsp;&raquo;&nbsp;</span><h4>NEXT</h4><p>First National Bank of Omaha Boosts Holdings in Old National Bancorp (NASDAQ:ONB)</p></div></a>			
			</nav><!-- end previous and next article links -->

			<div id="latest-news">
				<h2>More Articles</h2>
			 				 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/stitch-fix-inc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Zacks: Analysts Expect Stitch Fix Inc  to Post $0.06 EPS" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2020/01/19/zacks-analysts-expect-stitch-fix-inc-nasdaqsfix-to-post-0-06-eps.html" rel="bookmark">Zacks: Analysts Expect Stitch Fix Inc  to Post $0.06 EPS</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/progressive-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Zeke Capital Advisors LLC Sells 146 Shares of Progressive Corp " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2020/01/19/zeke-capital-advisors-llc-sells-146-shares-of-progressive-corp-nysepgr.html" rel="bookmark">Zeke Capital Advisors LLC Sells 146 Shares of Progressive Corp </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/northeast-utilities-system-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Alpha Cubed Investments LLC Grows Stake in Eversource Energy " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2020/01/19/alpha-cubed-investments-llc-grows-stake-in-eversource-energy-nysees.html" rel="bookmark">Alpha Cubed Investments LLC Grows Stake in Eversource Energy </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/phillips-66-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Citigroup Lowers Phillips 66  Price Target to $128.00" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2020/01/19/citigroup-lowers-phillips-66-nysepsx-price-target-to-128-00.html" rel="bookmark">Citigroup Lowers Phillips 66  Price Target to $128.00</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/vodafone-group-plc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Vodafone Group&#8217;s  Overweight Rating Reiterated at Barclays" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2020/01/19/vodafone-groups-vod-overweight-rating-reiterated-at-barclays.html" rel="bookmark">Vodafone Group&#8217;s  Overweight Rating Reiterated at Barclays</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/workspace-group-plc-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Workspace Group  Earns Hold Rating from Peel Hunt" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2020/01/19/workspace-group-lonwkp-earns-hold-rating-from-peel-hunt.html" rel="bookmark">Workspace Group  Earns Hold Rating from Peel Hunt</a>
				</div>
	 						</div><!-- end latest news -->

<!-- second ad spot -->


<br>
	</main> <!-- end main -->

	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<footer class="full-width">
			<div class="width-limiter">

				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a href="https://rivertonroll.com/business">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://rivertonroll.com/entertainment">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://rivertonroll.com/health-care">Health Care</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://rivertonroll.com/industry">Industry</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://rivertonroll.com/research">Research</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://rivertonroll.com/sports">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://rivertonroll.com/world-news">World News</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2006-2020 <a href="https://rivertonroll.com">Riverton Roll</a>
					</span>
				</div><!-- end #footer-info -->

			</div>	
		</footer>
		<script type='text/javascript' src='https://rivertonroll.com/wp-includes/js/wp-embed.min.js?ver=5.0.8'></script>
	
<!-- Start of StatCounter Code for Riverton Roll -->
<script type="text/javascript">
var sc_project=11450080; 
var sc_invisible=1; 
var sc_security="bc674887"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="//c.statcounter.com/11450080/0/bc674887/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for Riverton Roll -->

<!-- Start of StatCounter Code for Finance Articles -->
<script type="text/javascript">
	var sc_project=9021069; 
	var sc_invisible=1; 
	var sc_security="fdde5482"; 
	var sc_https=1; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/"></noscript>
<!-- End of StatCounter Code for Finance Articles -->


<!-- Begin Social Sharing -->
		<div style="top:25%;left:0;position:fixed;width:50px;z-index:20;box-sizing:content-box;" class="mobile-hide">
	<div style="background-color:#305891;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.facebook.com/sharer/sharer.php?u=https://rivertonroll.com/news/2020/01/19/meag-munich-ergo-kapitalanlagegesellschaft-mbh-makes-new-investment-in-fortis-inc-nysefts.html" target="_blank"><img src="/images/social-fb.png" style="margin:0;padding:0;" alt="share news on Facebook"></a></div>
	<div style="background-color:#2CA8D2;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://twitter.com/intent/tweet?text=Meag Munich Ergo Kapitalanlagegesellschaft MBH Makes New Investment in Fortis Inc $NYSE:FTS https://rivertonroll.com/news/2020/01/19/meag-munich-ergo-kapitalanlagegesellschaft-mbh-makes-new-investment-in-fortis-inc-nysefts.html" target="_blank"><img src="/images/social-tw.png" style="margin:0;padding:0;" alt="tweet this investment news"></a></div>
	<div style="background-color:#007BB6;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.linkedin.com/cws/share?mini=true&url=https://rivertonroll.com/news/2020/01/19/meag-munich-ergo-kapitalanlagegesellschaft-mbh-makes-new-investment-in-fortis-inc-nysefts.html" target="_blank"><img src="/images/social-in.png" style="margin:0;padding:0;" alt="share on linkedin"></a></div>
	<div style="background-color:#89120a;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://stocktwits.com/widgets/share?via=AnalystRatingsNetwork&body=Meag Munich Ergo Kapitalanlagegesellschaft MBH Makes New Investment in Fortis Inc $NYSE:FTS https://rivertonroll.com/news/2020/01/19/meag-munich-ergo-kapitalanlagegesellschaft-mbh-makes-new-investment-in-fortis-inc-nysefts.html" target="_blank"><img src="/images/social-st.png" style="margin:0;padding:0;box-sizing:content-box;" alt="share on StockTwits"></a></div>
	<div style="background-color:#FF1A00;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.reddit.com/submit?url=https://rivertonroll.com/news/2020/01/19/meag-munich-ergo-kapitalanlagegesellschaft-mbh-makes-new-investment-in-fortis-inc-nysefts.html&title=Meag Munich Ergo Kapitalanlagegesellschaft MBH Makes New Investment in Fortis Inc (NYSE:FTS)" target="_blank"><img src="/images/social-reddit.png" style="margin:0;padding:0;" alt="share on reddit"></a></div>
	</div>
	<!-- End Social Sharing -->

<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=46012072&PostDate=2020-1-19&type=f&id=6365080&domain=rivertonroll.com&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->


<!-- Start of StatCounter Code for Updated Articles -->
<!-- End of StatCounter Code for Updated Articles -->

<!-- Default Statcounter Code for Active GN Sites -->
<script type="text/javascript">
var sc_project=12038725; 
var sc_invisible=1; 
var sc_security="4f9c00a6"; 
var sc_https=1; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><div class="statcounter"><a title="Web Analytics" href="https://statcounter.com/" target="_blank"><img class="statcounter" src="https://c.statcounter.com/12038725/0/4f9c00a6/1/" alt="Web Analytics"></a></div></noscript>
<!-- End of Statcounter Code -->

	</body>

</html>