<!doctype html>
<html lang="en">

<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
 <meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
 <meta name="google-site-verification" content="4GrvUcextHKMFj91p1HDoOkOw9cvgqpM9_PmZtIoSDE" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="norton-safeweb-site-verification" content="4-8q940c68tts8mkrawweyw-fb0a-n0z-hr50v9pgp3alu7yrtpnma8cbusdizeq5y9-i8ztd697gah1hnnckhcmfuc99-gljisqjinmyn7xy8teaglw2fafhn5s0zue" />
<meta name="viewport" content="width=1040">

<!-- Escape from Frames  -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script>
<link href="https://fonts.googleapis.com/css?family=Roboto" rel="stylesheet">
<link rel="stylesheet" href="https://rivertonroll.com/wp-content/themes/alambre/style.css?1533069294" type="text/css" media="screen, projection" />

<link href="https://rivertonroll.com/feed" rel="alternate" title="Riverton Roll RSS Feed" type="application/rss+xml" />
<link href="https://rivertonroll.com/feed/atom" rel="alternate" title="Riverton Roll Atom Feed" type="application/atom+xml" />
<link href="https://rivertonroll.com/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://rivertonroll.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://rivertonroll.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://rivertonroll.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://rivertonroll.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Girard Partners LTD. Purchases New Position in Alibaba Group Holding Ltd (NYSE:BABA)' href='https://rivertonroll.com/news/2020/02/07/girard-partners-ltd-purchases-new-position-in-alibaba-group-holding-ltd-nysebaba.html' />
<link rel='next' title='Buckingham Asset Management LLC Invests $2.43 Million in Truist Financial Corporation (NYSE:TFC)' href='https://rivertonroll.com/news/2020/02/07/buckingham-asset-management-llc-invests-2-43-million-in-truist-financial-corporation-nysetfc.html' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="https://rivertonroll.com/news/2020/02/07/william-blair-weighs-in-on-royal-caribbean-cruises-ltds-q1-2020-earnings-nysercl.html" />
<link rel='shortlink' href='https://rivertonroll.com/?p=3861795' />
<link rel="alternate" type="application/json+oembed" href="https://rivertonroll.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frivertonroll.com%2Fnews%2F2020%2F02%2F07%2Fwilliam-blair-weighs-in-on-royal-caribbean-cruises-ltds-q1-2020-earnings-nysercl.html" />
<link rel="alternate" type="text/xml+oembed" href="https://rivertonroll.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frivertonroll.com%2Fnews%2F2020%2F02%2F07%2Fwilliam-blair-weighs-in-on-royal-caribbean-cruises-ltds-q1-2020-earnings-nysercl.html&#038;format=xml" />
<link rel="amphtml" href="https://rivertonroll.com/news/2020/02/07/william-blair-weighs-in-on-royal-caribbean-cruises-ltds-q1-2020-earnings-nysercl.html/amp" /><link rel="icon" href="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-logo-256-white-150x150.png" sizes="32x32" />
<link rel="icon" href="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-logo-256-white.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-logo-256-white.png" />
<meta name="msapplication-TileImage" content="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-logo-256-white.png" />

<!-- Start Meta Data -->

<title>William Blair Weighs in on Royal Caribbean Cruises Ltd&#8217;s Q1 2020 Earnings (NYSE:RCL) - Riverton Roll</title>


<meta name="description" content="Royal Caribbean Cruises Ltd (NYSE:RCL) &#8211; Investment analysts at William Blair decreased their Q1 2020 earnings per share estimates for shares of Royal Caribbean Cruises in a research report issued on Tuesday, February 4th. William Blair analyst S. Zackfia now forecasts that the company will post earnings per share of $0.60 for the quarter, down [&hellip;]" />
<meta name="author" content="Rob Hiaasen">
<meta name="news_keywords" content="Royal Caribbean Cruises,NYSE:RCL,RCL,Consumer Discretionary,V7780T10,Earnings Estimates,William Blair" />
<meta name="keywords" content="Royal Caribbean Cruises,NYSE:RCL,RCL,Consumer Discretionary,V7780T10,Earnings Estimates,William Blair" />
<meta name="ticker" content="NYSE:RCL" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@RatingsNetwork" />
<meta name="twitter:title" content="William Blair Weighs in on Royal Caribbean Cruises Ltd&#8217;s Q1 2020 Earnings (NYSE:RCL)"/>
<meta name="twitter:description" content="Royal Caribbean Cruises Ltd (NYSE:RCL) &#8211; Investment analysts at William Blair decreased their Q1 2020 earnings per share estimates for shares of Royal Caribbean Cruises in a research report issued on Tuesday, February 4th. William Blair analyst S. Zackfia now forecasts that the company will post earnings per share of $0.60 for the quarter, down [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/royal-caribbean-cruises-ltd-logo.png" />

<!-- Open Graph Data -->
<meta property="og:title" content="William Blair Weighs in on Royal Caribbean Cruises Ltd&#8217;s Q1 2020 Earnings (NYSE:RCL)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://rivertonroll.com/news/2020/02/07/william-blair-weighs-in-on-royal-caribbean-cruises-ltds-q1-2020-earnings-nysercl.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/royal-caribbean-cruises-ltd-logo.png" />
<meta property="og:description" content="Royal Caribbean Cruises Ltd (NYSE:RCL) &#8211; Investment analysts at William Blair decreased their Q1 2020 earnings per share estimates for shares of Royal Caribbean Cruises in a research report issued on Tuesday, February 4th. William Blair analyst S. Zackfia now forecasts that the company will post earnings per share of $0.60 for the quarter, down [&hellip;]" />
<meta property="og:site_name" content="Riverton Roll" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2020-02-07T15:52:42+0000" />
<meta property="article:modified_time" content="2020-02-07T15:52:42+0000" />
<meta property="article:tag" content="NYSE:RCL" />
<meta property="article:tag" content="Royal Caribbean Cruises,NYSE:RCL,RCL,Consumer Discretionary,V7780T10,Earnings Estimates,William Blair" />
<meta property="article:section" content="Investment" />

<!-- Google meta is in the body-->


	<meta name="googlebot" content="unavailable_after: 2020-04-07T15:52:42+0000" />
<!-- End Meta Data -->

	
<script type='text/javascript'>var PopupAdChannel=''; </script>

  <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'rivertonroll.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "467d2940-348c-4e60-8aab-3f08a21baf03",
      safari_web_id: 'web.onesignal.auto.27841aa0-90c9-472e-b116-e68b5f82c9c6', 
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
	if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}  
  </script>

  <script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
<!-- IMS header goes here -->
	
	<script type="text/javascript">
		var apntag = apntag || {};
		apntag.anq = apntag.anq || [];
		(function() {
			var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
			e.type = 'text/javascript';  e.async = true;
			e.src = '//acdn.adnxs.com/ast/ast.js';
			p.insertBefore(e, p.firstChild);
		})();

		
		apntag.anq.push(function() {
			apntag.setPageOpts({
				member: 6989
			});
		});

		apntag.anq.push(function() {

      		apntag.defineTag({
				tagId: 13685716,
				sizes: [[300,250]],
				keywords: {'position': ['RightRail_1']},
				targetId: 'RivertonRoll_ROS_RightRail_1'
			});

		apntag.anq.push(function() {
			apntag.loadTags();
		});
		});
		</script>
	
<script type="text/javascript">
(function() {
window.advBidxc = window.advBidxc || {};
window.advBidxc.startTime = new Date().getTime();
function loadScript(tagSrc) {
var scriptTag = document.createElement('script'),
placeTag = document.getElementsByTagName("script")[0];
scriptTag.type = 'text/javascript';
scriptTag.async = true;
scriptTag.src = tagSrc;
placeTag.parentNode.insertBefore(scriptTag, placeTag);
}
var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' +
window.location.hostname;
loadScript(mnSrc);
})();
</script>
	<!-- end IMS -->

	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>
	
	

		<!-- Gemini Tag -->
	<script type="application/javascript">(function(w,d,t,r,u){w[u]=w[u]||[];w[u].push({'projectId':'10000','properties':{'pixelId':'423827'}});var s=d.createElement(t);s.src=r;s.async=true;s.onload=s.onreadystatechange=function(){var y,rs=this.readyState,c=w[u];if(rs&&rs!="complete"&&rs!="loaded"){return}try{y=YAHOO.ywa.I13N.fireBeacon;w[u]=[];w[u].push=function(p){y([p])};y(c)}catch(e){}};var scr=d.getElementsByTagName(t)[0],par=scr.parentNode;par.insertBefore(s,scr)})(window,document,"script","https://s.yimg.com/wi/ytc.js","dotq");</script>

</head>

<body>

<!-- Start MarketBeat Modern Popup -->
	<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=52"></script>

	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Riverton Roll', 'rivertonroll.com', 'NYSE:RCL', 'Royal Caribbean Cruises', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/royal-caribbean-cruises-ltd-logo.png');</script>
	<!-- End MarketBeat Modern Popup -->
	
<header>
<div id="top-bar">
		<div class="width-limiter">
				<!-- top nav bar -->
				<nav class="navigation"><ul id="menu-header-menu" class="menu"><li id="menu-item-30" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30"><a href="https://rivertonroll.com/about-us">About Us</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-29"><a href="https://rivertonroll.com/contact-us">Contact Us</a></li>
<li id="menu-item-28" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28"><a href="https://rivertonroll.com/privacy-policy">Privacy Policy</a></li>
</ul></nav>		</div><!-- end: width-limiter in top-bar -->
	</div><!-- end: top-bar -->

	<div class="width-limiter add-padding"><!-- start: width-limiter with logo and space for alternate header unit -->
		<a class="logo-link" href="https://rivertonroll.com"><img id="logo" src="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-280-90-logo.png" alt="Riverton Roll logo"></a>

		<!----- Begin  header unit  ----->
		<div id="AlternateHeaderUnit">
<!-- Network Wide AdSense Unit - Header Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="5679141823" data-ad-format="horizontal" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
</div> 

<!-- End Header Unit-->
	</div> <!-- end: width-limiter with logo and space for alternate header unit -->

	<div id="menu">
		<div class="width-limiter" id="nav-main">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-main-menu" class="menu"><li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a href="https://rivertonroll.com/business">Business</a></li>
<li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://rivertonroll.com/entertainment">Entertainment</a></li>
<li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://rivertonroll.com/health-care">Health Care</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://rivertonroll.com/industry">Industry</a></li>
<li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://rivertonroll.com/research">Research</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://rivertonroll.com/sports">Sports</a></li>
<li id="menu-item-16" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://rivertonroll.com/world-news">World News</a></li>
</ul></nav>
			

				<form id="searchform" action="https://rivertonroll.com/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" placeholder="Search" />
						<input class="searchsubmit" type="submit" value="" />
					</div>
				</form><!-- end: searchform -->
		</div> <!-- end: width-limiter for menu -->

	</div> <!-- end: menu -->

</header> <!-- end: header -->
	<div class="width-limiter main-content">
		
<aside>
	
	<div>
		
<!-- Begin Dianomi Unit -->
<iframe width="336" height="670" scrolling="NO" src="//www.dianomi.com/smartads.epl?id=3355" style="width: 336px; max-width:100%; border: none; overflow: hidden;"></iframe>
<!-- End Dianomi Unit -->
	</div>

<div>
<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
	</div>
	
	<div>
<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
	</div>
	



<!-- OptIn Form -->
<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for Royal Caribbean Cruises</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for Royal Caribbean Cruises with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="Riverton Roll-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:RCL" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>
<!-- End Sidebar Registration -->

<!-- social media would go here -->
<!-- IMS unit -->
	<div id="RivertonRoll_ROS_RightRail_1" class="text-center">
			<script type="text/javascript">
			apntag.anq.push(function() {
				apntag.showTag('RivertonRoll_ROS_RightRail_1');
			});
			</script>
		</div>
<!-- end IMS unit -->

<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Recent Posts</h3>
            <ul>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/research-analysts-issue-forecasts-for-merck-co-inc-s-q1-2020-earnings-nysemrk.html">Research Analysts Issue Forecasts for Merck &#038; Co., Inc.&#8217;s Q1 2020 Earnings (NYSE:MRK)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/pennsylvania-capital-management-inc-adv-buys-shares-of-41080-apple-inc-nasdaqaapl.html">Pennsylvania Capital Management Inc. ADV Buys Shares of 41,080 Apple Inc. (NASDAQ:AAPL)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/cambridge-investment-research-advisors-inc-increases-holdings-in-honeywell-international-inc-nysehon.html">Cambridge Investment Research Advisors Inc. Increases Holdings in Honeywell International Inc. (NYSE:HON)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/apple-inc-nasdaqaapl-shares-purchased-by-moody-national-bank-trust-division.html">Apple Inc. (NASDAQ:AAPL) Shares Purchased by Moody National Bank Trust Division</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/ishares-core-sp-500-etf-nysearcaivv-stake-increased-by-cambridge-investment-research-advisors-inc.html">iShares Core S&#038;P 500 ETF (NYSEARCA:IVV) Stake Increased by Cambridge Investment Research Advisors Inc.</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/apple-inc-nasdaqaapl-shares-sold-by-pineno-levin-ford-asset-management-inc.html">Apple Inc. (NASDAQ:AAPL) Shares Sold by Pineno Levin &#038; Ford Asset Management Inc.</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/parsec-financial-management-inc-sells-9044-shares-of-microsoft-co-nasdaqmsft.html">Parsec Financial Management Inc. Sells 9,044 Shares of Microsoft Co. (NASDAQ:MSFT)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/microsoft-co-nasdaqmsft-shares-sold-by-providence-wealth-advisors-llc.html">Microsoft Co. (NASDAQ:MSFT) Shares Sold by Providence Wealth Advisors LLC</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/baltimore-washington-financial-advisors-inc-purchases-1655-shares-of-emerson-electric-co-nyseemr.html">Baltimore Washington Financial Advisors Inc. Purchases 1,655 Shares of Emerson Electric Co. (NYSE:EMR)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/jefferies-financial-group-comments-on-nxp-semiconductors-nvs-q1-2020-earnings-nasdaqnxpi.html">Jefferies Financial Group Comments on NXP Semiconductors NV&#8217;s Q1 2020 Earnings (NASDAQ:NXPI)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/calton-associates-inc-sells-391-shares-of-waste-management-inc-nysewm.html">Calton &#038; Associates Inc. Sells 391 Shares of Waste Management, Inc. (NYSE:WM)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/cynosure-management-llc-sells-64-shares-of-ishares-core-sp-500-etf-nysearcaivv.html">Cynosure Management LLC Sells 64 Shares of iShares Core S&#038;P 500 ETF (NYSEARCA:IVV)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/brokers-offer-predictions-for-nxp-semiconductors-nvs-q1-2020-earnings-nasdaqnxpi.html">Brokers Offer Predictions for NXP Semiconductors NV&#8217;s Q1 2020 Earnings (NASDAQ:NXPI)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/quad-cities-investment-group-llc-sells-1582-shares-of-apple-inc-nasdaqaapl.html">Quad Cities Investment Group LLC Sells 1,582 Shares of Apple Inc. (NASDAQ:AAPL)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/john-g-ullman-associates-inc-decreases-holdings-in-microsoft-co-nasdaqmsft.html">John G Ullman &#038; Associates Inc. Decreases Holdings in Microsoft Co. (NASDAQ:MSFT)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/apple-inc-nasdaqaapl-is-prestige-wealth-management-group-llcs-5th-largest-position.html">Apple Inc. (NASDAQ:AAPL) is Prestige Wealth Management Group LLC&#8217;s 5th Largest Position</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/genovese-burford-brothers-wealth-retirement-plan-management-llc-purchases-706-shares-of-microsoft-co-nasdaqmsft.html">Genovese Burford &#038; Brothers Wealth &#038; Retirement Plan Management LLC Purchases 706 Shares of Microsoft Co. (NASDAQ:MSFT)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/microsoft-co-nasdaqmsft-shares-sold-by-chartwell-investment-partners-llc.html">Microsoft Co. (NASDAQ:MSFT) Shares Sold by Chartwell Investment Partners LLC</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/cedar-mountain-advisors-llc-buys-shares-of-1278-apple-inc-nasdaqaapl.html">Cedar Mountain Advisors LLC Buys Shares of 1,278 Apple Inc. (NASDAQ:AAPL)</a></li>
                        <li class="recent-posts"><a href="https://rivertonroll.com/news/2020/02/07/buckingham-asset-management-llc-invests-2-43-million-in-truist-financial-corporation-nysetfc.html">Buckingham Asset Management LLC Invests $2.43 Million in Truist Financial Corporation (NYSE:TFC)</a></li>
                        </ul>
        </div>  
<!-- end recent posts -->

</aside><!--end #sidebar-->
		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://rivertonroll.com/news/2020/02/07/william-blair-weighs-in-on-royal-caribbean-cruises-ltds-q1-2020-earnings-nysercl.html" />
				<div class="page-title">
				<h1 itemprop="headline">William Blair Weighs in on Royal Caribbean Cruises Ltd&#8217;s Q1 2020 Earnings (NYSE:RCL)</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://rivertonroll.com/news/author/xrob" title="Posts by Rob Hiaasen" rel="author">Rob Hiaasen</a></span></span> on <span itemprop="datePublished dateModified" content="2020-02-07T15:52:42+0000">Feb 7th, 2020</span> 
				</p><!--end .postmeta-->

				<div style="clear:both"></div>
				</div>
				<!--sse-->
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					
					<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/royal-caribbean-cruises-ltd-logo.png" alt="Royal Caribbean Cruises logo" title="Royal Caribbean Cruises logo" class="companylogo" /></p>
<p>Royal Caribbean Cruises Ltd (NYSE:RCL) &#8211; Investment analysts at  William Blair decreased their Q1 2020 earnings per share estimates for shares of Royal Caribbean Cruises  in a research report issued on  Tuesday, February 4th. William Blair analyst S. Zackfia now forecasts that the company will post earnings per share of $0.60 for the quarter, down from their previous forecast of $1.07. William Blair currently  has a &#8220;Buy&#8221; rating on the stock. William Blair also issued estimates for Royal Caribbean Cruises&#8217; Q2 2020 earnings at $2.96 EPS, Q4 2020 earnings at $1.76 EPS and FY2021 earnings at $11.60 EPS. </p>


<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Riverton Roll"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:RCL" />    <label for="InPostRegistrationEmail">Get <b>Royal Caribbean Cruises</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></input></div>
</form>
<div id="ShowSuggestionInPost"></div>
		


<p>Royal Caribbean Cruises (NYSE:RCL) last announced its quarterly earnings data on Tuesday, February 4th. The company reported $1.42 EPS for the quarter, topping the consensus estimate of $1.41 by $0.01. Royal Caribbean Cruises had a net margin of 17.16% and a return on equity of 17.06%. The company had revenue of $2.52 billion during the quarter, compared to the consensus estimate of $2.54 billion. During the same quarter last year, the firm posted $1.53 EPS. The company&#8217;s quarterly revenue was up 7.9% on a year-over-year basis. </p>

<div style="float:left;margin:5px 10px 10px 0;width:340px;">
<!-- Network Wide AdSense Unit - In-Post Position -->
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9254111670"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
</div>
				 

					<p>A number of other equities research analysts also recently issued reports on RCL. Cfra upped their price objective on shares of Royal Caribbean Cruises from $120.00 to $135.00 and gave the stock a &#8220;buy&#8221; rating in a research report on Tuesday. SunTrust Banks lowered their price objective on shares of Royal Caribbean Cruises from $157.00 to $156.00 and set a &#8220;buy&#8221; rating on the stock in a research report on Thursday, January 30th. <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?Zacks=1'>Zacks Investment Research</a> cut shares of Royal Caribbean Cruises from a &#8220;hold&#8221; rating to a &#8220;sell&#8221; rating and set a $133.00 target price on the stock. in a research note on Wednesday, December 18th. Berenberg Bank lowered Royal Caribbean Cruises from a &#8220;buy&#8221; rating to a &#8220;hold&#8221; rating and increased their price objective for the company from $125.00 to $127.00 in a report on Friday, January 17th. Finally, Deutsche Bank  reiterated a &#8220;buy&#8221; rating and set a $138.00 target price on shares of Royal Caribbean Cruises in a research report on Thursday, October 31st. Two analysts have rated the stock with a sell rating, three have given a hold rating and ten have given a buy rating to the company&#8217;s stock. The company presently has an average rating of &#8220;Buy&#8221; and a consensus target price of $143.85.</p>
<p><a href='https://www.marketbeat.com/stocks/NYSE/RCL/earnings/' target='_blank' rel="noopener noreferrer">RCL</a> opened at $116.67 on Friday. Royal Caribbean Cruises has a fifty-two week low of $100.47 and a fifty-two week high of $135.32. The firm has a market capitalization of $24.78 billion, a PE ratio of 13.05, a P/E/G ratio of 1.25 and a beta of 1.45. The company has a debt-to-equity ratio of 0.74, a current ratio of 0.15 and a quick ratio of 0.15. The company&#8217;s 50-day moving average is $129.14 and its 200 day moving average is $116.24. </p>
<p>A number of institutional investors and hedge funds have recently modified their holdings of the business. Cullen Frost Bankers Inc. purchased a new position in shares of  Royal Caribbean Cruises in the 3rd quarter worth about $31,000.  Tobias Financial Advisors Inc. purchased a new position in shares of  Royal Caribbean Cruises during the fourth quarter valued at approximately $41,000.  FinTrust Capital Advisors LLC raised its holdings in shares of  Royal Caribbean Cruises by 40.9% during the fourth quarter. FinTrust Capital Advisors LLC now owns 362 shares of the company&#8217;s stock valued at $48,000 after purchasing an additional 105 shares during the last quarter.  Global Retirement Partners LLC lifted its position in  Royal Caribbean Cruises by 122.7% during the fourth quarter. Global Retirement Partners LLC now owns 363 shares of the company&#8217;s stock valued at $48,000 after purchasing an additional 200 shares during the period.  Finally, FTB Advisors Inc. lifted its position in  Royal Caribbean Cruises by 33.5% during the third quarter. FTB Advisors Inc. now owns 367 shares of the company&#8217;s stock valued at $39,000 after purchasing an additional 92 shares during the period. Institutional investors and hedge funds own  72.84% of the company&#8217;s stock. </p>
<p>In other Royal Caribbean Cruises news, CEO Lawrence R. Pimentel sold 10,928 shares of the company&#8217;s stock in a transaction that occurred on Tuesday, November 26th. The stock was sold at an average price of $120.00, for a total transaction of $1,311,360.00. Following the completion of the transaction, the chief executive officer now owns 58,335 shares of the company&#8217;s stock, valued at approximately $7,000,200. The transaction was disclosed in a filing with the Securities &amp; Exchange Commission, which is available at <a href="https://www.sec.gov/Archives/edgar/data/884887/000156761919022370/xslF345X03/doc1.xml" target='_blank' rel="noopener noreferrer">the SEC website</a>. Also, CEO Richard D. Fain sold 20,000 shares of the company&#8217;s stock in a transaction that occurred on Monday, January 6th. The shares were sold at an average price of $131.07, for a total value of $2,621,400.00. Following the transaction, the chief executive officer now directly owns 787,850 shares of the company&#8217;s stock, valued at approximately $103,263,499.50. The disclosure for this sale can be found <a href="https://www.sec.gov/Archives/edgar/data/884887/000156761920000729/xslF345X03/doc1.xml" target='_blank' rel="noopener noreferrer">here</a>. Insiders sold 70,928 shares of company stock valued at $8,737,560 in the last quarter. Corporate insiders own  13.07% of the company&#8217;s stock. </p>
<p><strong>Royal Caribbean Cruises Company Profile</strong></p>
<p>Royal Caribbean Cruises Ltd. operates as a cruise company. The company operates cruises under the Royal Caribbean International, Celebrity Cruises, Azamara Club Cruises, and Silversea Cruises brands. The Royal Caribbean International brand provides itineraries to destinations worldwide, including Alaska, Asia, Australia, Bahamas, Bermuda, Canada, the Caribbean, Europe, the Panama Canal, and New Zealand with cruise lengths that range from 2 to 23 nights.</p>
<p>Read More: <a href='https://www.marketbeat.com/financial-terms/what-is-call-option/'>What is a Call Option?</a> <!--ViewCount:ArticleHistoryID=47048577&PostDate=2020-2-7&type=r&id=785498--></p>
<p><!--Keyword: Royal Caribbean Cruises,NYSE:RCL,RCL,Consumer Discretionary,V7780T10,Earnings Estimates,William Blair--><!--Ratings:4,13,NYSE:RCL--></p>
<p style='text-align:center'><img src='https://www.marketbeat.com/scripts/EarningsEstimatesChart.ashx?Prefix=NYSE&#038;Symbol=RCL' alt='Earnings History and Estimates for Royal Caribbean Cruises (NYSE:RCL)' title='Earnings History and Estimates for Royal Caribbean Cruises (NYSE:RCL)' /></p>

			 	<!-- end inline unit -->

				<!-- end main text -->

				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->


<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for Royal Caribbean Cruises Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Royal Caribbean Cruises and related companies with <a href="/daily-email-updates-basic/?symbol=NYSE:RCL&c=Royal+Caribbean+Cruises" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="Riverton Roll-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:RCL" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->


				</div> <!-- end: entry -->
				<!--/sse-->
				 
				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=300&h=300&zc=1&src=https://www.marketbeat.com/logos/royal-caribbean-cruises-ltd-logo.png" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://rivertonroll.com/wp-content/uploads/2019/05/riverton-roll-280-90-logo.png">
 						<meta itemprop="height" content="90">
						 <meta itemprop="width" content="280">
					 </div>
					<meta itemprop="name" content="Riverton Roll"/>
					<meta itemprop="url" content="https://rivertonroll.com" />
 				</div>
				<!-- end article metadata -->

			</article>

		<!-- IMS below post -->
		<div id="rivertonroll_ros_belowpost_1"></div><br><br>
<!-- end IMS below post -->
		

			<!-- start Dianomi – sponsored content -->
			<iframe style="max-width:100%" width="654" height="787" scrolling="no" src="//www.dianomi.com/smartads.epl?id=2341"></iframe>
			<!-- end sponsored content -->

			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://rivertonroll.com/news/2020/02/07/girard-partners-ltd-purchases-new-position-in-alibaba-group-holding-ltd-nysebaba.html" rel="prev"><div class="previous"><span class="left">&nbsp;&laquo;&nbsp;</span><h4>PREVIOUS</h4><p>Girard Partners LTD. Purchases New Position in Alibaba Group Holding Ltd (NYSE:BABA)</p></div></a>				<a href="https://rivertonroll.com/news/2020/02/07/buckingham-asset-management-llc-invests-2-43-million-in-truist-financial-corporation-nysetfc.html" rel="next"><div class="next"><span class="right">&nbsp;&raquo;&nbsp;</span><h4>NEXT</h4><p>Buckingham Asset Management LLC Invests $2.43 Million in Truist Financial Corporation (NYSE:TFC)</p></div></a>			
			</nav><!-- end previous and next article links -->

			<div id="latest-news">
				<h2>More Articles</h2>
			 				 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/neurocrine-biosciences-logo.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Research Analysts Set Expectations for Neurocrine Biosciences, Inc.&#8217;s Q1 2020 Earnings " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2020/02/07/research-analysts-set-expectations-for-neurocrine-biosciences-inc-s-q1-2020-earnings-nasdaqnbix.html" rel="bookmark">Research Analysts Set Expectations for Neurocrine Biosciences, Inc.&#8217;s Q1 2020 Earnings </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/merck--co-inc-logo.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Research Analysts Issue Forecasts for Merck &#038; Co., Inc.&#8217;s Q1 2020 Earnings " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2020/02/07/research-analysts-issue-forecasts-for-merck-co-inc-s-q1-2020-earnings-nysemrk.html" rel="bookmark">Research Analysts Issue Forecasts for Merck &#038; Co., Inc.&#8217;s Q1 2020 Earnings </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/apple-inc-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Pennsylvania Capital Management Inc. ADV Buys Shares of 41,080 Apple Inc. " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2020/02/07/pennsylvania-capital-management-inc-adv-buys-shares-of-41080-apple-inc-nasdaqaapl.html" rel="bookmark">Pennsylvania Capital Management Inc. ADV Buys Shares of 41,080 Apple Inc. </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/6hon_logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Cambridge Investment Research Advisors Inc. Increases Holdings in Honeywell International Inc. " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2020/02/07/cambridge-investment-research-advisors-inc-increases-holdings-in-honeywell-international-inc-nysehon.html" rel="bookmark">Cambridge Investment Research Advisors Inc. Increases Holdings in Honeywell International Inc. </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/apple-inc-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Apple Inc.  Shares Purchased by Moody National Bank Trust Division" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2020/02/07/apple-inc-nasdaqaapl-shares-purchased-by-moody-national-bank-trust-division.html" rel="bookmark">Apple Inc.  Shares Purchased by Moody National Bank Trust Division</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="iShares Core S&#038;P 500 ETF  Stake Increased by Cambridge Investment Research Advisors Inc." />
						<br/>
				 <!--end: longthumb-->
						<a href="https://rivertonroll.com/news/2020/02/07/ishares-core-sp-500-etf-nysearcaivv-stake-increased-by-cambridge-investment-research-advisors-inc.html" rel="bookmark">iShares Core S&#038;P 500 ETF  Stake Increased by Cambridge Investment Research Advisors Inc.</a>
				</div>
	 						</div><!-- end latest news -->

<!-- second ad spot -->


<br>
	</main> <!-- end main -->

	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<footer class="full-width">
			<div class="width-limiter">

				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a href="https://rivertonroll.com/business">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://rivertonroll.com/entertainment">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://rivertonroll.com/health-care">Health Care</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://rivertonroll.com/industry">Industry</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://rivertonroll.com/research">Research</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://rivertonroll.com/sports">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16"><a href="https://rivertonroll.com/world-news">World News</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2006-2020 <a href="https://rivertonroll.com">Riverton Roll</a>
					</span>
				</div><!-- end #footer-info -->

			</div>	
		</footer>
		<script type='text/javascript' src='https://rivertonroll.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
	
<!-- Start of StatCounter Code for Riverton Roll -->
<script type="text/javascript">
var sc_project=11450080; 
var sc_invisible=1; 
var sc_security="bc674887"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="//c.statcounter.com/11450080/0/bc674887/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for Riverton Roll -->

<!-- Start of StatCounter Code for Finance Articles -->
<script type="text/javascript">
	var sc_project=9021069; 
	var sc_invisible=1; 
	var sc_security="fdde5482"; 
	var sc_https=1; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/"></noscript>
<!-- End of StatCounter Code for Finance Articles -->


<!-- Begin Social Sharing -->
		<div style="top:25%;left:0;position:fixed;width:50px;z-index:20;box-sizing:content-box;" class="mobile-hide">
	<div style="background-color:#305891;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.facebook.com/sharer/sharer.php?u=https://rivertonroll.com/news/2020/02/07/william-blair-weighs-in-on-royal-caribbean-cruises-ltds-q1-2020-earnings-nysercl.html" target="_blank"><img src="/images/social-fb.png" style="margin:0;padding:0;" alt="share news on Facebook"></a></div>
	<div style="background-color:#2CA8D2;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://twitter.com/intent/tweet?text=William Blair Weighs in on Royal Caribbean Cruises Ltd&#8217;s Q1 2020 Earnings $NYSE:RCL https://rivertonroll.com/news/2020/02/07/william-blair-weighs-in-on-royal-caribbean-cruises-ltds-q1-2020-earnings-nysercl.html" target="_blank"><img src="/images/social-tw.png" style="margin:0;padding:0;" alt="tweet this investment news"></a></div>
	<div style="background-color:#007BB6;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.linkedin.com/cws/share?mini=true&url=https://rivertonroll.com/news/2020/02/07/william-blair-weighs-in-on-royal-caribbean-cruises-ltds-q1-2020-earnings-nysercl.html" target="_blank"><img src="/images/social-in.png" style="margin:0;padding:0;" alt="share on linkedin"></a></div>
	<div style="background-color:#89120a;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://stocktwits.com/widgets/share?via=AnalystRatingsNetwork&body=William Blair Weighs in on Royal Caribbean Cruises Ltd&#8217;s Q1 2020 Earnings $NYSE:RCL https://rivertonroll.com/news/2020/02/07/william-blair-weighs-in-on-royal-caribbean-cruises-ltds-q1-2020-earnings-nysercl.html" target="_blank"><img src="/images/social-st.png" style="margin:0;padding:0;box-sizing:content-box;" alt="share on StockTwits"></a></div>
	<div style="background-color:#FF1A00;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.reddit.com/submit?url=https://rivertonroll.com/news/2020/02/07/william-blair-weighs-in-on-royal-caribbean-cruises-ltds-q1-2020-earnings-nysercl.html&title=William Blair Weighs in on Royal Caribbean Cruises Ltd&#8217;s Q1 2020 Earnings (NYSE:RCL)" target="_blank"><img src="/images/social-reddit.png" style="margin:0;padding:0;" alt="share on reddit"></a></div>
	</div>
	<!-- End Social Sharing -->

<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=47048577&PostDate=2020-2-7&type=r&id=785498&domain=rivertonroll.com&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->


<!-- Start of StatCounter Code for Updated Articles -->
<!-- End of StatCounter Code for Updated Articles -->

<!-- Default Statcounter Code for Active GN Sites -->
<script type="text/javascript">
var sc_project=12038725; 
var sc_invisible=1; 
var sc_security="4f9c00a6"; 
var sc_https=1; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><div class="statcounter"><a title="Web Analytics" href="https://statcounter.com/" target="_blank"><img class="statcounter" src="https://c.statcounter.com/12038725/0/4f9c00a6/1/" alt="Web Analytics"></a></div></noscript>
<!-- End of Statcounter Code -->

	</body>

</html>